Tower Bridge in London

Architecture, Uncategorized 1 Apr 07

I assume everyone knows where this is. Yes that’s right, Toronto. Of course its actually London. Just before taking this shot I missed the bridge going up, which was a bit annoying. I need to go back when there’s a dramatic sky and HDR this bridge. I imagine it will look fantastic.

In other news my 30D still isn’t working right. 5 shots then err99. I’ve tried everything. I’ll ring Canon on Monday and discuss things. However after using a Nikon D200 the other day while at the Aperture event I must admit that I am very tempted to swap. I think I’ll get the 30D fixed and look into ebaying it. I reckon I could get enough for my current gear, especially with the 100-400 to get a nice D200 + 10-20 and 24-70. Sure people say they’re noisy but I like that. In a couple of days I could have a NikonD200 category.

Comments 9

  1. Mike says on 1 Apr 07

    I like the post production that nicely frames the bridge itself.

  2. Stephen says on 1 Apr 07

    I assume you’ve tried a different memory card in the camera? I once had a memory card that would get to a certain number of shots then give a similar error each time. As for moving from Canon to Nikon, wow, what a jump! Good luck with whatever you do.

  3. Adam says on 1 Apr 07

    Nice processing on this! I call April Fools on the Nikon switch

  4. Maarten says on 1 Apr 07

    don’t switch to nikon – April Fools for me too -> You like noise ???? Don’t think so :p

  5. Graham Hind says on 1 Apr 07

    Great stuff – and as you sold me on the Sigma 10-20 it would be good to see you come over to a D200. Truly a great camera.

  6. Andy M says on 1 Apr 07

    Pete, if you’re getting ‘Err99’ I reckon it’s likely to be a fault with your Sigma lens. The exact same problem I had.
    Does it still occur with Canon lenses?

    Also, Nikon?!! Pull the other one… ;)

Comments are closed.